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Creating Accessible PDF 
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• Please note: This webinar is being recorded and the materials will be 
available at www.DisabilitySmallBusiness.org on the Past Events page 
within 1-2 weeks. 

 

 

 

  

http://www.disabilitysmallbusiness.org/
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What we will Cover Today: 

● Common PDF usage 

● PDFs Advantages and disadvantages 

● Use Tools to check PDF accessibility 

● Create Workflow and learn how to 
approach the process of making 
PDFs accessible 

● Making a PDF accessible 
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What is an accessible pdf, and why does it matter? 

An accessible PDF is a document that is universally easy to use and meets 
established accessibility standards. It enables most people to view, read, or 
interact with your document. Since your audience may include people whose 
vision, hearing, mobility, or cognition is impaired, it’s important that your document 
be easy to use with assistive technology like: 

● Screen readers 

● Text-to-speech programs 

● Braille displays 

The more accessible your PDF is, for example, the easier it is to hear on a mobile 
device. Or view with a screen magnifier. Or fill out without a keyboard. Actually, this 
increased ease of use benefits everyone in your audience, regardless of their 
various abilities. So let’s dive in further: what is PDF accessibility, and how can you 
apply it in your next document? 

 

Why is PDF accessibility so important?  

● Unlike a sighted user who physically 
views and reads the contents of a PDF 
document, a user with vision 
impairment or other disabilities, such as 
color blindness, hearing loss, or certain 
cognitive challenges, relies on tools 
such as a screen reader to access 
PDFs. 

● If a PDF is not made accessible, a screen reader does not read it as it 
should be read, preventing the user from fully accessing the information 
contained in the PDF document. 

● Your goal is to make your PDF accessible to as many people as 
possible.  
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Common PDF usage 

PDF can give us more versatility than plain word documents, they 
can hold some interactive capabilities and have an overall better 
image presentation. 

So it is common for PDFs to be: 

● Technical documents and manuals 

● Reports, especially with complex layouts, graphs, charts, etc. 

● Forms meant for print or online delivery 

● Scanners and other hardware that output PDF 

● Print and design industry 

● Large and/or complex documents published on websites 

 

Most common PDF accessibility barriers 

● A lack of ability to navigate the documents to find what was needed; 

● Incomprehensible tables; 

● Text not ordered correctly, or not spaced properly between words so 
everything is read as an unintelligible jumble; 

● No alt text for images, charts, and graphs; 

● Inability to interact with fillable forms; and 

● Scanned documents that have no content and must be OCR’d resulting in 
inaccuracies and the document having no structure at all.  
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PDFs Advantages and disadvantages 

Advantage: 

1. PDFs are designed to be structured in such a way that allows remediation 
from a structural level without the excessive need to make visual changes. 

2. The ease of modification for navigation within the PDF. 

3. If the source document you have is accessible, then making the resulting 
PDF accessible is much easier. 

Disadvantage: 

1. Security can be a negative from an accessibility point of view, a secured 
PDF might interfere with screen readers and automated testers.  

2. PDFs can be composed solely of images, but an image is still an image and 
still requires alt text. This can be difficult when we are working with scans 
from a textbook. 
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Making a PDF accessible 

We will go over some important steps for you to consider. 

 

Use Tools to check PDF Accessibility 

Use Tools to check PDF accessibility 
(automated, manual, and assistive technology) 

You can start with an accessible base program like 
inDesign, CommonLook office, etc.  

Always review the document with a screen reader 
(JAWS or NVDA) 

There is an automated accessibility checker on 
Acrobat Pro, as a big note it tests against WCAG 
2.0, a standard that could be considered outdated 
but PDF was added to WCAG on 2.0. 

https://www.w3.org/TR/WCAG20-TECHS/pdf  

AxesPDF tests for WCAG 2.0 

CommonLook tests for WCAG 2.0 

  

https://www.w3.org/TR/WCAG20-TECHS/pdf
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Check accessibility of PDFs (Acrobat Pro) 

A good way to check the accessibility of a document is to use tools that 
your readers will use. Even if you do not have access to those tools, Adobe 
Acrobat provides an automated way to check the accessibility of a PDF file. 
The Full Check/Accessibility Check feature in Acrobat checks a PDF for 
many of the characteristics of accessible PDFs. You can choose which 
accessibility problems to look for and how you want the results reported. 

1. Choose Tools > Accessibility. 

2. The Accessibility toolset is displayed in 
the secondary toolbar. 

3. In the secondary toolbar, click Full 
Check/Accessibility Check. 

4. The Accessibility Checker Options dialog 
box is displayed. 

5. In the Report Options section, select 
options for how you want to view the results. 
You can save the results as an HTML file on 
your system, or attach the results file to the 
document itself. 

6. Select a page range if you prefer to check 
individual pages of a document. 

 

 

 

Note:  

When you have a large document, running a full check/accessibility check one 
page at a time can be more efficient. 

1. Select one or more of the Checking Options. 
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2. Click Start Checking. The results are displayed in the Accessibility Checker 
panel on the left, which also has helpful links and hints for repairing issues. 
If you created a report in step 2, the results are available in the selected 
folder. 

3. Because the Full Check/Accessibility Check feature cannot distinguish 
between essential and nonessential content types, some issues it reports 
don’t affect readability. It’s a good idea to review all issues to determine 
which ones require correction. 

The report displays one of the following statuses for each rule check: 

● Passed: The item is accessible. 

● Skipped By User: Rule was not checked because it wasn't selected in the 
Accessibility Checker Options dialog box. 

● Needs Manual Check: The Full Check/Accessibility Check feature couldn't 
check the item automatically. Verify the item manually. 

● Failed: The item didn't pass the accessibility check. 

It’s worth mentioning that you will need acrobat pro in order to run the 
accessibility check 
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Create Workflow and learn how to approach the process of making 
PDFs accessible 

 

We are going to go over some steps that you will need to take in order to make a 
pdf accessible. 

Make sure you use your drafting program to the maximum of its capacity InDesign 
and word both have tagging systems, using them will help when the file is 
converted or exported into a PDF. Once you have a PDF you go through it using 
assistive technologies this will give you an idea of what you have to correct. 

Then you evaluate the PDF using an automated tool again I prefer CommonLook 
but it’s just an example here this is the step where we fix all the content issues we 
might find, so if something wasn’t tagged correctly or if something doesn’t have alt 
text we add it here. We make sure we did a good job with our assistive 
technologies by going back to correct if there is something we got wrong. 
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Workflow Example 

 

1. Make sure you use your drafting program to the maximum of it-s capacity 
InDesign and word both have tagging systems, using them will help when 
the file is converted or exported into a PDF. 

2. Once you have a PDF you go through it using assistive technologies this will 
give you an idea of what you have to correct. 

3. Then you evaluate the PDF using an automated tool again I prefer 
CommonLook but it’s just an example here this is the step where we fix all 
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the content issues we might find, so if something wasn’t tagged correctly or 
if something doesn’t have alt text we add it here. 

4. We make sure we did a good job with our assistive technologies going back 
to correct if there is something we got wrong 

5. We add our metadata. 
6. Then we finally publish or share the PDF  

 

Exported PDF 

You can make a PDF accessible from the start by ensuring that 
the file is accessible in the authoring software (word, InDesign, 
etc.) any authoring software by Microsoft and by adobe will 
have a basic accessibility check option. Our recommendation 
is to use the basic tools as best as you can always reading 
carefully and only when the content passes those checks to 
export into a pdf. 

These checks function great for very simple pdfs, complex pdfs 
that contain several charts tables, forms, etc. might need a 
second look for confirmation. 

There are also services that remediate pdf documents, we at results one offer this 
service, some documents just have a lot of complex content and if you do not feel 
secure with the basic check you can approach a professional to remediate the 
document for you. 
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OCR or Optical Character Recognition 

Can recognize scanned text and convert it to the actual text, however, this is not a 
perfect fix you will need to read the results in order to ensure that it is correct. 

The resulting text will be searchable, selectable, and assistive technologies will be 
able to read it. OCR still needs to be tagged in order to be accessible. 

 

 

Set the correct reading order with Tags 

Tags can be created by automation, again they are not always right, more and 
more issues with automated tagging occur when the document is more complex. 

Tagging a document will create a ‘tag tree’, representing its structure and 
components, this tag tree is what is mostly perceived by screen readers. A PDF 
MUST be tagged in order to be considered Accessible. 

Tags can be edited 
using the tag panel 
(Choose View > 
Show/Hide > 
Navigation Panels > 
Content).  
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How to edit tags 

 

Tags can be edited using the tag panel (Choose View > Show/Hide > Navigation 
Panels > Content). 

 

Tagging Tables 
 

Tables need to be reviewed all the time while tagging to ensure the reading order 
is correct. 

1. Open the "Reading Order" tool in the right-hand Accessibility menu. 

2. Find the incorrectly tagged table within the document. 

3. Select all elements that should be included in the table. 

4. Right-click on selection and select "Tag as Table". 
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In each Table there should be "<Table>" tag, which once expanded will show: 

● "<TR>" for Table Rows 

● "<TH>" for Table Header cells and should only be in the first TR of the 
Table.  

● "<TD>" for Table Data cells  

● Cells that span two or more rows or columns should use the RowSpan or 
ColSpan attribute. 

● For tables that contain blank cells, you may need to add empty TD cells so 
that each row or column has the same number of cells. 

Tagging Tables Example 

● Table <table> 

○ Table header row <TR> 

■ Table header cell <TH> 

■ Table header cell <TH> 

■ Table header cell <TH> 

○ Table row <TR>  
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■ Table data cell <TD> 

■ Table data cell <TD> 

■ Table data cell <TD> 

○ Table row <TR>  

■ Table data cell <TD> 

■ Table data cell <TD> 

■ Table data cell <TD> 
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Tagging Forms 

When Acrobat adds form fields automatically, it also automatically adds a Name 
and Tooltip to each field based on text near the field. You should review each 
Tooltip. If you added the fields manually, the Tooltip will be blank. 

With the Prepare Form tool group open, right-click a form field and choose 
Properties.  

 

Make sure the text in the Tooltip conveys all the information a screen reader needs 
to correctly complete the field, and correct it if it does not. 

You must make sure forms are tagged and are still functional after being tagged, 
make sure that they are in the correct order in the tag tree. 

Make sure instructions are clear and do not rely on any visual input to complete, 
input like color and directions using right or left are not acceptable. 
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Set Alt-Text 

We’ve spoken about how to write alt text before but in PDFs, it's important to 
consider that complex images like charts might need a description instead of alt-
text, additionally always make sure the alt is accurate. Any decorative images 
should not have alt text and should be removed from the tag tree. 

 

Color and contrast 

Color and contrast rules still apply so 4.5:1 contrast ratio is the acceptable one for 
regular text and 3:1 for larger text. Color and contrast rules apply to all elements. 
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Text resize 

Any text must be resizable up to 200%, regular text size is considered from 12pts 
minimum and large text is 18 pts. 

 

 

Remove notes 

An accessible PDF cannot have notes left from previous reviews or embedded 
speaker notes.  

Screen readers can understand them but it is common for them to cause a 
keyboard trap or be ignored. They do not belong in the tag tree. 
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Set the bookmarks 

 

Add bookmarks as a penultimate step. 
If your tag tree was made correctly 
automated bookmarks should be 
accurate. 

Always review them to make sure 
everything is covered. You can edit 
them. There must be bookmarks for 
any document over 9 pages. 

 

Set Metadata 

• Title, Author, Subject, Keywords, and Language.  

Documents over 5 pages must include a page number, Metadata will help with 
the SEO. Adobe Acrobat and go to File > Properties > Description. 
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What’s next? 

Send One (1) PDF to kalfonsodc@resultsonellc.com for a FREE automated audit 

Once the Automated Audit is conducted; we will send you a link to schedule your 
thirty-minute consultation.  

We will review your results from the automated audit; 

● Discuss next steps for the manual audit;  

● Address any questions you might have; 

Upcoming Events 

Funding Your Business 

Presented by Griffin-Hammis Associates  

Wednesday, June 21, 2:00 – 3:30PM EST 

Creating Accessible Emails 

Presented by Result One 

Wednesday, July 12, 2:00 – 3:00PM EST 

Net Earning from Self-Employment and SSDI/ Medicare  

Presented by Griffin-Hammis Associates  

Wednesday, July 19, 2:00 – 3:30PM EST 

NDI Small Business Hub 

• Are you an aspiring entrepreneur or existing business owner with a disability 
wanting help to START, BUILD and GROW your business?  Visit 
www.disabilitysmallbusiness.org or email rchavez@ndi-inc.org 

• Want to join a dynamic learning community focused on key financial health 
topics for business, such as budgeting, managing cash flow, risk 
management, insurance, taxes, building credit, and loan and grant 

mailto:kalfonsodc@resultsonellc.com
https://us02web.zoom.us/meeting/register/tZIpd-CppzoqHt13ffT00JN89OiKFv0-FMdy
https://us02web.zoom.us/meeting/register/tZcrc-6qrDMvEtZvicEy702NV0g8y8mCNgmD
https://us02web.zoom.us/meeting/register/tZcqd-6oqT8rGtx40jRPcwNYFYSMavLkpvox
http://www.disabilitysmallbusiness.org/
mailto:rchavez@ndi-inc.org
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applications? Apply at  
https://ndiinc.formstack.com/forms/advancing_financial_health_application 
or email cbolas@ndi-inc.org for more information. 

• Visit our Streaming TV channel for informational and motivational content for 
disability owned small businesses at www.DisabilityOwned.com 

• Access training, mentoring, business coaching, and grant opportunities 
through our new partnership with Verizon Small Business Digital Ready! 
Register here: Small Business Training | About Verizon 

• Want to “Stay In The Know” about NDI’s small business hub? Join our 
mailing list!  

NDI Small Business Team  

Nikki Powis, Director  

Small Business Programs 

npowis@ndi-inc.org 

 

 

 

 

Ruth Chavez, Small Business Community 
Navigator 

rachvez@ndi-inc.org 

 

 

https://ndiinc.formstack.com/forms/advancing_financial_health_application
https://ndiinc.formstack.com/forms/advancing_financial_health_application
mailto:cbolas@ndi-inc.org
http://www.disabilityowned.com/
https://www.verizon.com/about/responsibility/digital-inclusion/small-business-training?utm_source=national-disability-institute&utm_medium=partner&utm_campaign=digital-ready-launch&utm_term=national-washington-dc
https://realeconomicimpact.us8.list-manage.com/subscribe?u=ea6584491b7ab9daf6b074fe6&id=04574865cd
mailto:npowis@ndi-inc.org
mailto:rachvez@ndi-inc.org
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Caroline Bolas, Small Business Specialist 

cbolas@ndi-inc.org 

 

 

 

 

 

Caroline Bolas, Small Business Specialist 

cbolas@ndi-inc.org 

 

mailto:cbolas@ndi-inc.org
mailto:cbolas@ndi-inc.org
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